IP forwarding ?

[Résolu/Fermé]
Signaler
Messages postés
12
Date d'inscription
jeudi 19 octobre 2006
Statut
Membre
Dernière intervention
30 octobre 2006
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
voici ma configuration :
j'ai une passerelle avec Unbuntu server avec 2 cartes réseaux, l'une de ses cartes est connectee au modem, l'autre à la machine bureautique (winXp) :

modem(192.168.30.1)-----eth1(192.168.30.10)UBUNTU(192.168.0.2)eth0-----BUR0TIC
mon modem fait office de serveur DHCP pour UBUNTU, j'ai installe un serveur DHCP sur UBUNTU pour BUROTIC.

sur UBUNTU, je peux pinguer eth0, eth1, le modem et un ping sur google marche tres bien.
tout est ok de ce cote.

sur BUROTIC, je peux pinguer eth0 et c'est tout. Le serveur DHCP installé sur UBUNTU fait bien son travail, j'ai bien une adresse IP apres un ipconfig /renew.

Mais je ne peux pinguer eth1, ni le modem.
il semble qu'il n'y ai pas de communication entre eth0 et eth1 (vu par BUROTIC)
quel est le pb ?

nota : j'ai bien activer l'IP forwarding dans /proc/sys/net/ipv4/ip_forward.


je suis bloquee.

merci
Sophie

25 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 545
Sophie écoute kelux,

N'enleve pas ton dhcp,ce n'est pas parce que lami20j n'a pas mis de dhcp chez lui que tu dois l'enlever aussi. Sa config elle marche tant mieux, pour l'instant la tienne n'a pas avancé...


Si tu utilise dhcp mieux vaut écouter kelux.

lami20j
Messages postés
12
Date d'inscription
jeudi 19 octobre 2006
Statut
Membre
Dernière intervention
30 octobre 2006

non !!!
j'ai besoin d'aide !

j'essaye de faire au plus simple, d'elaguer le probleme pour avoir le moins de trucs parasites.

ok je vais appliquer les modifs, et en + je prefere n'avoir qu'une route par default...

merci

sophie
Messages postés
12
Date d'inscription
jeudi 19 octobre 2006
Statut
Membre
Dernière intervention
30 octobre 2006

bonne nouvelle : ca marche !

j'ai retire la gw de interfaces et j'ai mis la passerelle XP en 192.168.0.2
et c'est bon !
je suis contente.....

j'ai retire la gw de /etc/network/interfaces et j'ai passe la passerelle en 192.168.0.2

et dans le script Fw :
iptables -t nat -A POSTROUTING -o eth1 -s 192.168.0.0/24 -j MASQUERADE

maintenant que j'ai une config propre, je vais essayer :
1 - de passer en IP statique sur eth1 donc ne pas utiliser le serveur DHCP du modem
2 - consolider mon script FW.



Merci a vous 2, votre aide à ete tres preciseuse.

S.
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 545
Salut à tous,

Félicitations Sophie.
Merci pour les remarques kelux. Je vais essayer d'être plus explicite pour la prochaine fois.

j'ai retire la gw de interfaces et j'ai mis la passerelle XP en 192.168.0.2
C'est ça que j'ai dit dans ip forwarding#29
# passerelle défaut: 192.168.0.1 - ici mets 192.168.0.2

lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 545
Salut,


nota : j'ai bien activer l'IP forwarding dans /proc/sys/net/ipv4/ip_forward.


Ce n'est pas suffisant.

il faut configurer la table NAT et la chaine FORWARD de la table FILTER de ton firewall sous Ubuntu.
iptables -A FORWARD -i eth1 -o eth0 -s 0.0.0.0/0 -d x.x.x.x -m --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i eth0 -o eth1 -s x.x.x.x -d 192.168.30.0/0  -m --state ! INVALID -j ACCEPT

iptables -t nat -A POSTROUTING -o eth1 -s x.x.x.x -j SNAT --to-source 192.168.30.10


Donc configure en local ton winxp en utilisant un IP dans le réseau 192.168.0.0 (par exemple 192.168.0.3 - c'est en fait x.x.x.x

Ex: ipconfig de mon xp

        Connection-specific DNS Suffix  . : 

        Description . . . . . . . . . . . : NVIDIA nForce Networking Controller

        Physical Address. . . . . . . . . : 00-30-1B-B6-7E-1F

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : 192.168.1.2

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . : 10.0.0.2

        DNS Servers . . . . . . . . . . . : 212.27.32.176

                                            212.27.32.177


il faut aussi utilisé comme passerelle par défaut pour winxp l'IP de ton interface qui sort sur net (192.168.30.10) ainsi que les DNS de ton FAI.

Regarde ici ma config pour mieux comprendre, ainsi que le firewall minimal pour que ça marche.
C'est la même que la tienne avec la différence que je sors sur net depuis linux la passerelle avec eth0 et pas eth1. ubuntu reseau#35

lami20j

Sur les mêmes thèmes