Symfony 5 : Problème de route - liens actifs

Signaler
Messages postés
17
Date d'inscription
jeudi 19 juillet 2018
Statut
Membre
Dernière intervention
2 mai 2020
-
Bonjour

Voila je rencontre un petit problème avec mon code sous Symfony 5

Lorsque je lance le site, ce message d'erreur apparaît :

An exception has been thrown during the rendering of a template ("Unable to generate a URL for the named route "publicite" as such route does not exist.").

Mon fichier DevSecureCenterController.php
<?php

namespace App\Controller;

use Symfony\Bundle\FrameworkBundle\Controller\AbstractController;
use Symfony\Component\Routing\Annotation\Route;


class DevSecureCenterController extends AbstractController
{
    /**
     * @Route("/", name="dev_secure_center")
     */
    public function index()
    {
        return $this->render('dev_secure_center/index.html.twig');
    }


    /**
     * @Route("/about", name="about")
     */
    public function about()
    {
        return $this->render('dev_secure_center/about.html.twig');
    }

    /**
     * @Route("/pub", name="publicite")
     */
    public function pub()
    {
        return $this->render('dev_secure_center/publicite.html.twig');
    }

    /**
     * @Route("/services", name="services")
     */
    public function services()
    {
        return $this->render('dev_secure_center/services.html.twig');
    }
}


Mon fichier base.html.twig a pour MENU
<li class=""><a href="{{path('dev_secure_center')}}">Accueil</a></li>
<li class=""><a href="{{path('about')}}">A propos</a></li>
<li class=""><a href="{{path('publicite')}}">Espace publicitaire</a></li>
<li class=""><a href="{{path('services')}}">Services</a></li>
<li class="smooth-menu"><a href="#project">Projets</a></li>
<li class="smooth-menu"><a href="#team">Portfolio</a></li>
<li class="smooth-menu"><a href="#blog">Blog</a></li>


Mon fichier publicite.html.twig

{% extends 'base.html.twig' %}

{% block body %}

    <h1>Bonjour le monde !</h1>

{% endblock %}


En gros ma route publicite n'existe pas alors qu'elle est bien présente..
il n'arrive pas à la trouver.

Est ce que quelqu'un aurait une explication à cette erreur ?

Merci d'avance pour vos retours