Macro : permettre une SOMMEPROD entre deux classeurs

Fermé
cooljuly44 - 26 mai 2016 à 11:06
Bonjour,

j'ai un gros soucis avec ma macro. Afin d'alléger mon fichier final, j'ai dû le séparer en 3 classeurs.
du coup je dois corriger des formules de calcul.
mon soucis c'est que je n'arrive pas (ne sais pas faire) à mettre en place le calcul entre 2 classeurs différents sans que l'on soit obligé d'ouvrir à chaque fois le fichier organigrammes

les fichiers seront toujours dans un même répertoire (qui est sur un réseau avec un chemin à rallonge)
voici la formule en texte :
=SOMMEPROD(([consolidation des organigramme - onglet Cumul!$D$2:$BT$2=B$6)*([consolidation des organigramme - onglet Cumul!$D$3:$BT$3= $A7)*(DECALER([consolidation des organigramme - onglet Cumul!$D$3;EQUIV($B$4;[consolidation des organigramme - onglet Cumul!$C$4:$C$400; 0);;;69)))

pour récap : dans le fichier fiche de poste de B7 à J26 doivent venir apparaitre les montants selon le fonction ci-dessus.
fichier fiche de poste http://www.cjoint.com/c/FEAjeRxFSLw
fichier orga http://www.cjoint.com/c/FEAjfBaVdJw

un énorme merci à qui pourra me retirer cette épine du pied