Formule Excel si cellule contient un texte [Résolu/Fermé]

Signaler
Messages postés
92
Date d'inscription
lundi 14 décembre 2009
Statut
Membre
Dernière intervention
23 novembre 2016
-
 moi -
Bonjour à tous,

J'ai un léger soucis que je souhaiterais pouvoir faciliter par une formule.
Si ma cellule A1 contient le texte "NBR" alors écrire NBR en cellule B1
Sachant que la cellule A1 = O'Ring NBR 70 Shore A.

Comment faire ?

En attendant de vous lire,

Mathieu



7 réponses

Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
5 393
Bonjour
en B1
=SI(NB.SI(A1;"*NBR*");"NBR";"")

attention aux signes
crdlmnt
329
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 56980 internautes nous ont dit merci ce mois-ci

Post simple, efficace et fonctionnel. Merci.
merci beaucoup, super efficace!
Merci pour votre post !
Un grand merci, parfait pour mon utilisation. Je délaisse un peu trop le nb.si
Les vrai hero ne portent pas de cape

Merci
Salut Amaury,

=SI(NB.SI(A1;"*dimanche*");A2*1,2;"")

Voila
bonjour,
j'ai le même soucis, sauf que mon "samedi" vient d'une case qui comprend une formule qui permet d'afficher "samedi"

Case 1 = 13-12-2014 (sur feuil2)
Case 2 = =SI(Feuil2!A5="";"";Feuil2!A5) affichage de la cellule en [$-80C]jjjj
Case 3 = =SI(NB.SI(A15;"*samedi*");"40";"30")

Un grand merci si vous savez répondre.
Bonjour, tu as essayé de copier/coller ta cellule "samedi" en valeur ?
Messages postés
5477
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
6 août 2020
461
une idée

=DROITE(SUPPRESPACE(GAUCHE($A$1;CHERCHE(CONCATENER(CAR(78);CAR(66);CAR(82));$A$1;1)+NBCAR($A$2)));NBCAR(A2))

ou CAR(78) = N
CAR(66) = B
CAR(82) = R
NBCAR(A2) = le nombre de caratère rechercher
cherche(CONCATENER(assemble les trois caratéres et donne la position de départ)
SUPPRESPACE enléve les espaces inutiles
Gauche prend un nombre de caratéres à partir de la gauche, ce nombre est défini par la fonction chercher dans A1
Droite prend un nombre de caractéres à partir de la droite défini par NBCAR A2
Tu devrais pouvoir trouver ce que tu cherchers la :
http://www.yvoz.net/2010/09/excel-tester-chaine-caracteres-contient/
J'ai un soucis pour la première formule j'aimerais récupérer le *NBR* a partir de l'extraction d'une chaîne.
exple : je parcourir une liste d'element dans la colonne A, et trouver le nombre de fois qu'elle les elements de la colonne b. e
ssss pour compléter ma question
+NB.SI($H$12:$H$38;"*7*"),
la formule ci dessus pourrait répondre à mon besoin , mais "*7*" doit etre une variable qui est récupérer
dans une cellule.
Juste pour avoir un lien qui fonctionne
http://www.yvoz.net/2010/09/excel-tester-chaine-caracteres-contient/
Bonjour,

Dans la même lignée, comment faire :

Si cellule A1 contient "Dimanche" alors calculer "A2*1,2"

Ceci ne marche pas:
=SI(NB.SI(A1;"*dimanche*");"=A2*1,2";"")


Merci d'avance
=SI(NB.SI(A1;"*dimanche*");A2*1,2;"")
Bonjour,

Et si je veux que quand ma colonne A1 affiche FRANCE, ma colonne A2 mette FR, si elle n'affiche pas France, A2 affiche INT et si elle est vide, A2 reste vide?

Merci beaucoup
Bonjour Roxane,

Je pense que la réponse à ta question c'est les condition imbriquée comme précisait Ricky38.
=Si(A1="FRANCE";"FR";si(A1="";"";si(A1<>"FRANCE";"INT";)))

Quant à moi ma question serait :

Je veux faire : SI A1 = "TXT" ALORS A2 SINON 0
Et le TXT serait une case dans laquelle se trouve une liste déroulante. Est ce possible?

Merci par avance!
Réponse à ma propre question:
=SI(A1=K1;A2;0)
j'avais juste fait l'erreur d'écrire
=SI(A1="K1";A2;0)
Bonjour,

Je cherche une formule imbriquée qui me permette de saisir automatiquement l'adresse mail en me basant sur le prénom et nom des destinataires...

Si vs m'avais compris merci de m'aider :-)

Cordialement,
Salut tout le monde,
j'ai un problème aussi sur Excel c'est que il faut que je parcours chaque colone et vérifier si le contenu de chaque celulle contient des caractères spéciaux si oui, il le remplace par des caractères normaux. aidez moi svp
Bonjour,

Je recherche une formule qui me permette de compter le nombre de case contenant une info exemple

SS AQ 010
SS AQ 011
SS AS 009
SS AT 003
SS AU 002
SS AU 008

La formule me permettrai de déterminer qu'il y'a 2 cellule contenant les lettre AQ, 1 cellule contenant les lettres AS etc

en espérant avoir bien exposé ma demande