Problème d'installation phpmyadmin

[Fermé]
Signaler
Messages postés
1
Date d'inscription
jeudi 19 avril 2012
Statut
Membre
Dernière intervention
19 avril 2012
-
Bonjour,
Excusez-moi d'être un peu longue, mais je pense que ça vaut la peine.

Suis un peu perdue; aidez-moi s'il vous plait car j'ai déjà tenté maintes solutions mais rien.

En effet, j'ai installé un serveur web sur une VM Debian sur lequel j'ai configuré ssl et qui marche bien.
Ensuite, pour tester le bon fonctionnement de mon site avec ma base de données(connexion), il me fallait installer mysql et phpmyadmin; mysql fonctionne.Cependant, en installant phpmyadmin, après avoir donné le password du super-utilisateur, on me demande s'il faut configurer apache2; par précaution(puisque j'avais déja apache2 configuré)j'ai interrompu l'install pour sauvegarder d'abord ma VM; et c'est en reprenant l'install par la suite que tous les problèmes ont commencé. Voici toutes mes tentatives de solution et leurs résultats:

root@serveurweb-a:/home/tajo# apt-get install phpmyadmin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
dbconfig-common javascript-common libapache2-mod-php5 libgd2-xpm
libjs-mootools libmcrypt4 php5-cli php5-common php5-gd php5-mcrypt
php5-mysql wwwconfig-common
Paquets suggérés :
php-pear libgd-tools libmcrypt-dev mcrypt postgresql-client apache
apache-ssl
Les paquets suivants seront ENLEVÉS :
libgd2-noxpm
Les NOUVEAUX paquets suivants seront installés :
dbconfig-common javascript-common libgd2-xpm libjs-mootools libmcrypt4
php5-gd php5-mcrypt php5-mysql phpmyadmin wwwconfig-common
Les paquets suivants seront mis à jour :
libapache2-mod-php5 php5-cli php5-common
3 mis à jour, 10 nouvellement installés, 1 à enlever et 90 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/

root@serveurweb-a:/home/tajo# nano /var/cache/apt/archives/lock
root@serveurweb-a:/home/tajo# rm /var/cache/apt/archives/lock
root@serveurweb-a:/home/tajo# apt-get install phpmyadmin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
dbconfig-common javascript-common libapache2-mod-php5 libgd2-xpm
libjs-mootools libmcrypt4 php5-cli php5-common php5-gd php5-mcrypt
php5-mysql wwwconfig-common
Paquets suggérés :
php-pear libgd-tools libmcrypt-dev mcrypt postgresql-client apache
apache-ssl
Les paquets suivants seront ENLEVÉS :
libgd2-noxpm
Les NOUVEAUX paquets suivants seront installés :
dbconfig-common javascript-common libgd2-xpm libjs-mootools libmcrypt4
php5-gd php5-mcrypt php5-mysql phpmyadmin wwwconfig-common
Les paquets suivants seront mis à jour :
libapache2-mod-php5 php5-cli php5-common
3 mis à jour, 10 nouvellement installés, 1 à enlever et 90 non mis à jour.
Il est nécessaire de prendre 0 o/11,8 Mo dans les archives.
Après cette opération, 21,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Lecture des fichiers de modifications (« changelog »)... Terminé
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : libgd2-noxpm : problème de dépendance, mais suppression comme demandé :
libgvc5 dépend de libgd2-noxpm (>= 2.0.36~rc1~dfsg) | libgd2-xpm (>= 2.0.36~rc1~dfsg) ; cependant :
Le paquet libgd2-noxpm doit être supprimé.
Le paquet libgd2-xpm n'est pas installé.
(Lecture de la base de données... 135448 fichiers et répertoires déjà installés.)
Suppression de libgd2-noxpm ...
Sélection du paquet libgd2-xpm précédemment désélectionné.
(Lecture de la base de données... 135438 fichiers et répertoires déjà installés.)
Dépaquetage de libgd2-xpm (à partir de .../libgd2-xpm_2.0.36~rc1~dfsg-5_i386.deb) ...
Paramétrage de libgd2-xpm (2.0.36~rc1~dfsg-5) ...
Sélection du paquet dbconfig-common précédemment désélectionné.
(Lecture de la base de données... 135449 fichiers et répertoires déjà installés.)
Dépaquetage de dbconfig-common (à partir de .../dbconfig-common_1.8.46+squeeze.0_all.deb) ...
Sélection du paquet wwwconfig-common précédemment désélectionné.
Dépaquetage de wwwconfig-common (à partir de .../wwwconfig-common_0.2.1_all.deb) ...
Sélection du paquet javascript-common précédemment désélectionné.
Dépaquetage de javascript-common (à partir de .../javascript-common_7_all.deb) ...
Préparation du remplacement de php5-cli 5.3.3-7+squeeze3 (en utilisant .../php5-cli_5.3.3-7+squeeze8_i386.deb) ...
Dépaquetage de la mise à jour de php5-cli ...
Préparation du remplacement de libapache2-mod-php5 5.3.3-7+squeeze3 (en utilisant .../libapache2-mod-php5_5.3.3-7+squeeze8_i386.deb) ...
Dépaquetage de la mise à jour de libapache2-mod-php5 ...
Préparation du remplacement de php5-common 5.3.3-7+squeeze3 (en utilisant .../php5-common_5.3.3-7+squeeze8_i386.deb) ...
Dépaquetage de la mise à jour de php5-common ...
Sélection du paquet libjs-mootools précédemment désélectionné.
Dépaquetage de libjs-mootools (à partir de .../libjs-mootools_1.2.4.0~debian1-1_all.deb) ...
Sélection du paquet libmcrypt4 précédemment désélectionné.
Dépaquetage de libmcrypt4 (à partir de .../libmcrypt4_2.5.8-3.1_i386.deb) ...
Sélection du paquet php5-gd précédemment désélectionné.
Dépaquetage de php5-gd (à partir de .../php5-gd_5.3.3-7+squeeze8_i386.deb) ...
Sélection du paquet php5-mcrypt précédemment désélectionné.
Dépaquetage de php5-mcrypt (à partir de .../php5-mcrypt_5.3.3-7+squeeze8_i386.deb) ...
Sélection du paquet php5-mysql précédemment désélectionné.
Dépaquetage de php5-mysql (à partir de .../php5-mysql_5.3.3-7+squeeze8_i386.deb) ...
Sélection du paquet phpmyadmin précédemment désélectionné.
Dépaquetage de phpmyadmin (à partir de .../phpmyadmin_4%3a3.3.7-7_all.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de man-db (--unpack) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
configured to not write apport reports
Des erreurs ont été rencontrées pendant l'exécution :
man-db
E: Sub-process /usr/bin/dpkg returned an error code (1)


root@serveurweb-a:/home/tajo# nano /var/lib/dpkg/info/'man-db'.postinst
root@serveurweb-a:/home/tajo# apt-get install phpmyadmin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
phpmyadmin est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 90 non mis à jour.
13 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
Paramétrage de man-db (2.5.7-8) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de man-db (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de dbconfig-common (1.8.46+squeeze.0) ...
configured to not write apport reports
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de dbconfig-common (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de wwwconfig-common (0.2.1) ...
configured to not write apport reports
Paramétrage de javascript-common (7) ...
Paramétrage de php5-common (5.3.3-7+squeeze8) ...
Paramétrage de libapache2-mod-php5 (5.3.3-7+squeeze8) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de libapache2-mod-php5 (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de libjs-mootools (1.2.4.0~debian1-1) ...
configured to not write apport reports
Paramétrage de libmcrypt4 (2.5.8-3.1) ...
Paramétrage de php5-cli (5.3.3-7+squeeze8) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de php5-cli (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de php5-gd :
php5-gd dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-20090626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-gd (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de php5-mcrypt :
php5-mcrypt dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-2009configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
0626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-mcrypt (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de php5-mysql :
php5-mysql dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-20090626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-mysql (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de phpmyadmin :
phpmyadmin dépend de php5-mysql | php5-mysqli ; cependant :
Le paquet php5-mysql n'est pas encore configuré.
Le paquet php5-mysqli n'est pas installé.
phpmyadmin dépend de php5-mcrypt ; cependant :
Le paquet php5-mcrypt n'est pas encore configuré.
phpmyadmin dépend de dbconfig-common ; cependant :
Le paquet dbconfig-common n'est pas encore configuré.
dpkg : erreur de traitement de phpmyadmin (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
man-db
dbconfig-common
libapache2-mod-php5
php5-cli
php5-gd
php5-mcrypt
php5-mysql
phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@serveurweb-a:/home/tajo# apt-get -s install phpmyadmin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
phpmyadmin est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 90 non mis à jour.
8 partiellement installés ou enlevés.
Conf man-db (2.5.7-8 Debian:6.0.4/stable [i386])
Conf dbconfig-common (1.8.46+squeeze.0 Debian:6.0.4/stable [all])
Conf libapache2-mod-php5 (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-cli (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-gd (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-mcrypt (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-mysql (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf phpmyadmin (4:3.3.7-7 Debian:6.0.4/stable, Debian-Security:6.0/stable [all])

root@serveurweb-a:/home/tajo# apt-get -s install util-linux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
util-linux est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 90 non mis à jour.
8 partiellement installés ou enlevés.
Conf man-db (2.5.7-8 Debian:6.0.4/stable [i386])
Conf dbconfig-common (1.8.46+squeeze.0 Debian:6.0.4/stable [all])
Conf libapache2-mod-php5 (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-cli (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-gd (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-mcrypt (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf php5-mysql (5.3.3-7+squeeze8 Debian-Security:6.0/stable [i386])
Conf phpmyadmin (4:3.3.7-7 Debian:6.0.4/stable, Debian-Security:6.0/stable [all])

root@serveurweb-a:/home/tajo# apt-get install util-linux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
util-linux est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 90 non mis à jour.
8 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
Paramétrage de man-db (2.5.7-8) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de man-db (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de dbconfig-common (1.8.46+squeeze.0) ...
configured to not write apport reports
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de dbconfig-common (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de libapache2-mod-php5 (5.3.3-7+squeeze8) ...
configured to not write apport reports
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de libapache2-mod-php5 (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de php5-cli (5.3.3-7+squeeze8) ...
configured to not write apport reports
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ressource temporairement non disponible
dpkg : erreur de traitement de php5-cli (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de php5-gd :
php5-gd dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-20090626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-gd (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de php5-mcrypt :
php5-mcrypt dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-2009configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
0626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-mcrypt (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de php5-mysql :
php5-mysql dépend de phpapi-20090626+lfs ; cependant :
Le paquet phpapi-20090626+lfs n'est pas installé.
Le paquet libapache2-mod-php5 qui fournit phpapi-20090626+lfs n'est pas encore configuré.
Le paquet php5-cli qui fournit phpapi-20090626+lfs n'est pas encore configuré.
dpkg : erreur de traitement de php5-mysql (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de phpmyadmin :
phpmyadmin dépend de php5-mysql | php5-mysqli ; cependant :
Le paquet php5-mysql n'est pas encore configuré.
Le paquet php5-mysqli n'est pas installé.
phpmyadmin dépend de php5-mcrypt ; cependant :
Le paquet php5-mcrypt n'est pas encore configuré.
phpmyadmin dépend de dbconfig-common ; cependant :
Le paquet dbconfig-common n'est pas encore configuré.
dpkg : erreur de traitement de phpmyadmin (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
man-db
dbconfig-common
libapache2-mod-php5
php5-cli
php5-gd
php5-mcrypt
php5-mysql
phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@serveurweb-a:/home/tajo#

Aidez-moi, s'il vous plait!!!(je précise que phpmyadmin est quand meme dans les paquets installés
)
Merci d'avance!!!