Aide Condition Multiple EXCEL

Fermé
krakite - 21 avril 2011 à 10:55
Bonjour,

Je recherche un petit coup de main, car je cale sur un soucis avec Excel:

Mon but est de trouver une valeur de texte dans une colonne, Puis une fois trouver cette valeur de faire un clacul dans une cellule

Sachant que je ne connais pas a l'avance ce qui vas se trouver dans cette colonne, je recupere ces donnée d'un autre logiciel (mais je connais ce qui pourrais eventuellement s'y trouver ayant une base sur un autre fichier Excel)


Pour être plus clair, voici la fonction que j'utilise, mais qui dans mon cas est trop limité en nbr d'argument

=SI((B:B)="BASE TFOI428 1000M";C2*0,35;SI((B:B)="BASE TFOI428 550M";C2*0,3;SI((B:B)="BASE TFOI428 440M";C2*0,3)))

Donc si dans la colonne B on trouve le texte BASE TFOI428 1000M, je veut que ça me fasse un calcul sur la celulle C2, mais avec cette formule, je peut inseré que 7 arguments max, et je dois pouvoir faire une recherche sur une centaine d'article different.

D'avance merci, en espérant avoir été asses clair