Matplotlib 0.99.3 pour python 2.6.5

[Fermé]
Signaler
-
Bonjour,





Je viens d'installer ubuntu 10.04
celui-çi vient avec python 2.6.5

J'ai besoin de numpy. Si je prends "python-numpy" dans le gestionnaire de paquets, ça plante : import numpy donne "segmentation fault" parce que c'est encore la version 1.3.0
Je vais donc installer numpy 1.4.1, ce que je dois faire depuis les sources.
D'abord désinstaller python-numpy.
Ensuite rapatrier les sources numpy 1.4.1 et tenter d'installer. Bien entendu ça ne va pas. Il lui faut d'autres compilateurs, des librairies blas et lapack bien spéciales, etc...
Je dois avoir pyfits. Même cirque, si je prends dans les paquets "python-pyfits" tout foire.
Donc je dois tout rapatrier "à la main". C'est un foutu bordel, mais au bout de trois jours je finis par y arriver.

OK maintenant je dois installer scipy. Devinez quoi ... oui c'est le même cirque.
Puis pygtk, avec pango, cairo, etc ....
Mais pourquoi c'est donc systématiquement le même marécage avec ce foutu linux ? A chacun de leurs upgrades, j'en ai pour minimum une semaine de travail tellement ils ont merdé leurs paquets ! A la 7.10 j'en ai eu pour plus d'un mois avant que ça ne marche ! En windoze je n'ai pas ce problème.

Et je dois maintenant mettre matplotlib-pylab.
Je ne comprends toujours pas pourquoi l'un ou l'autre, ce n'est pas du tout clair.

Mais là, si je prends le python-matplotlib dans l'installateur de paquets, ça plante. Et fort : je dois désinstaller et réinstaller toutes les étapes mentionnées ci-dessus jusqu'à numpy.

Et si je prends matplotlib par les sources, le "sudo python setup.py build" me renvoie une floppée de messages d'erreur.

Que faire ????
Qui a réussi cette gageure d'installer matplotlib 0.99.3 sous ubuntu 10.04 ???

Je crains de devoir attendre des mois pour les correctifs....